Sie sind nicht angemeldet.

  • »hannoholgi« ist der Autor dieses Themas

Beiträge: 3 620

Registrierungsdatum: 12. November 2004

Wohnort: Am Hohen Ufer der Leine

Beruf: Funkenkutscher im Ruhestand

  • Nachricht senden

1

Mittwoch, 11. November 2015, 15:11

Millivoltmeter HP 3400A; Hilfe!

Hallo,

ich benötige mal die Hilfe eines erfahrenen Elektronikers, der auch etwas komplexere Schaltungen lesen kann, was mir als Hobbylöter nicht immer gegeben ist. :S
Ich besitze seit Kurzem ein True-RMS-Voltmeter Hewlett Packard 3400A. Ein ausgezeichnetes Gerät, eines der genauesten Analog-Wechselspannungsmesser. Sagt man. Es arbeitet mit Thermokopplern und kann daher die echten RMS-Werte von Signalen jeder beliebigen Form bis hin zum Rauschen korrekt messen.
Das tut es auch, allerdings mit einer Einschränkung: Die obere Frequenzgrenze ist viel zu niedrig! Es soll bis 10 MHz innerhalb von ±3% messen, der -3 dB-Punkt soll erst bei rund 20 Mhz liegen.

Mein Exemplar jedoch misst nur bis gut 500 kHz richtig, danach fällt die Empfindlichkeit stetig ab. Bei 10 MHz sind es bereits -11 dB. Mit dem dazu vorhandenen Trimmer lässt sich der Zeigerausschlag nur noch weiter verringern, nicht jedoch, wie es laut Abgleichanleitung sein sollte, so kompensieren, dass bei 10 Mhz weniger als 1 dB Abfall zu verzeichnen ist!

Ich habe daraufhin die meisten Elkos auf dem Videoverstärker durchgemessen. Die sind aber alle sehr gut in der Toleranz. Es sind auch nur hochwertige Typen von Sprague verbaut.
Die anschließende Spannungsmessung auf dem Board ergab eine erhebliche Abweichung: die Spannung am Kollektor der 1. Stufe soll -4,5 V betragen, es sind aber -9,65 V! Ebenso messe ich am Emitter von Q401 -0,03 statt -0,11 V. Alle anderen Spannungen auf der Platine stimmen mit den Angaben im Schaltbild innerhalb der üblichen Toleranzen überein.

Ich habe das Schaltbild gescannt und die fehlerhaften Werte in pink eingetragen. Der grün eingekringelte Trimmer soll eigentlich die Kompensation bei 10 MHz ermöglichen, schafft das aber nur bis -11 dB...

Vielleicht hat einer eine Idee, wie die falschen Spannungen verursacht werden könnten?!.... :huh:

LG Holgi

P.S.: Dieser Thread wurde parallel auch im Dualboard eröffnet. Mal sehen, wer schneller ist! 8o

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »hannoholgi« (11. November 2015, 15:16)


2

Mittwoch, 11. November 2015, 18:55

Die falschen Arbeitspunkte erst mal außer acht gelassen, wie sah den der Messaufbau aus?
Was war die Signalquelle (mit ausreichender Linearität?), wie war sie angeschlossen?
Auf den Widerstandsabschluß (50Ohm?) direkt am MV geachtet?
Eingangsabschwächer des HP korrekt abgeglichen?

Bei 10MHZ kommt man so langsam schon in Bereiche, bei denen man auf Wellenwiderstände (Generator + Kabel) und korrekte Terminierungen achten muss.

Nachtrag zum Thema Arbeitspunkte:



Diese Schaltbildversion passt schon besser.

Gruß Ulrich

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »uk64« (11. November 2015, 19:46)


  • »hannoholgi« ist der Autor dieses Themas

Beiträge: 3 620

Registrierungsdatum: 12. November 2004

Wohnort: Am Hohen Ufer der Leine

Beruf: Funkenkutscher im Ruhestand

  • Nachricht senden

3

Mittwoch, 11. November 2015, 20:19

Hallo Ulrich,

wo hast du denn dieses Schaltbild her? Ich habe in der mitgelieferten Anleitung nur das, das ich gescannt habe.

Die Signalquelle ist ein digitaler DDS-Generator, und zwar dieser.Ich habe leider keine andere Quelle, die bis 10 MHz geht. Meinem Oszi und den technischen Daten zufolge ist die Amplitude dieses Geräts aber bis 10 MHz konstant.

Angeschlossen ist er über ein 25 cm langes RG-58U mit zwei BNC-Steckern. Der 50 Ohm Widerstandsabschluss ist allerdings nicht gegeben. Habe ich vorhin erst irgendwo in der Anleitung gefunden, dass der vorhanden sein soll. Ich weiß allerdings jetzt auf die Schnelle nicht, wie ich den realisieren soll. Das müsste ja dann schon ordentlich sein, mit Abschirmgehäuse und so. Hmm, mal sehen...
Der Eingangsabschwächer ist korrekt abgeglichen, auch die 1/10-Skalenwert-Anzeige und die 100 kHz-Kompensation im 1 V-Bereich.

Gruß Holgi

4

Mittwoch, 11. November 2015, 20:39

Schaltbild:

http://elektrotanya.com/hp_3400a_rms_vol…f/download.html

Die 50 Ohm Adapter kommen normalerweise direkt auf die Buches des MV, einfache BNC>BNC Durchgangsdinger.
Bei 25cm Messkabel (direkte Verbindung ohne irgendwelche T-Stücke) und 10MHz sollte der Wellenwiderstand aber noch Vernachlässigbar sein.

Gruß Ulrich

  • »hannoholgi« ist der Autor dieses Themas

Beiträge: 3 620

Registrierungsdatum: 12. November 2004

Wohnort: Am Hohen Ufer der Leine

Beruf: Funkenkutscher im Ruhestand

  • Nachricht senden

5

Mittwoch, 11. November 2015, 21:11

Okay, vielleicht hat der Frequenzgangabfall ja auch einen anderen Grund? Ich blicke bei der Schaltung leider nicht ganz durch. Vor diesem "Videoverstärker" befindet sich nur der doppelte Stufenschalter mit den beiden Spannungsteiler-Netzwerken und dazwischen ein Impedanzwandler mit einem FET und einem npn-Transistor.
Aber du hast ja jetzt auch die Schaltung, wenn auch offenbar mit anderen Messwerten...

6

Mittwoch, 11. November 2015, 21:27

Das Gerät ist immerhin fast 50 Jahre alt, da ist vieles möglich.
Eventuell einfach mal ein Rechteck (10kHz-100kHz) einspeisen und mit dem Oszi schauen wie es vom Eingang aus durch das Gerät kommt. Das geht eigentlich relativ zügig, da man am Rechteck Frequenzgangfehler schnell erkennt.

PS: Deine Messwerte machten mich stutzig, da sie in einer gleichspannungsgekoppelten Schaltung nicht nur an einem Transistor abweichen können.

Gruß Ulrich

  • »hannoholgi« ist der Autor dieses Themas

Beiträge: 3 620

Registrierungsdatum: 12. November 2004

Wohnort: Am Hohen Ufer der Leine

Beruf: Funkenkutscher im Ruhestand

  • Nachricht senden

7

Mittwoch, 11. November 2015, 22:06

Deine Messwerte machten mich stutzig, da sie in einer gleichspannungsgekoppelten Schaltung nicht nur an einem Transistor abweichen können.

...Woraus wir schließen können, dass die Werte in meinem Schaltplan wohl nicht korrekt sind.

  • »Jamomamo« wurde gesperrt

Beiträge: 179

Registrierungsdatum: 16. Oktober 2015

  • Nachricht senden

8

Donnerstag, 12. November 2015, 09:56

Mist Mist Doppelmist!

Holger, als du bei mir warst, hatte ich das 3400A noch im Keller stehen... Inzwischen ist es verscherbelt, und ich habe nur noch das kleine Schwesterlein, also das 400E. Wenn man gewusst hätte, was man jetzt weiß, hätte man sich ein Stündchen Zeit nehmen können zwecks Referenzmesserei.

Wegen der 50 Ohm: wenn du das 3400 eh aufgeschraubt hast, dann löte den 50 Ohm direkt an die Pins der BNC-Buchse. Ist aber - wie Ulrich schon geschrieben hat - bei 25cm Strippe nicht unbedingt erforderlich. (Ich würds trotzdem tun.) Sichergestellt sein muss aber, dass dein Generator diese 50 Ohm auch "treiben" kann.

Dass die Werte in deinem Schaltbild nicht korrekt sind, kann ich mir wenig vorstellen. HP hat diese Gerätereihe aber im Laufe der Jahrzehnte weiterentwickelt. Die ersten Geräte dieser Reihe hatten zum Beispiel statt des FET nach dem Eingangs-Spannungsteiler tatsächlich noch eine Röhre drinne... Es ist also tatsächlich möglich, dass angegebene Messwerte von Baureihe zu Baureihe voneinander abweichen. Deshalb könnte auch sein, dass die Unterlagen, die deinem Gerät mitgeliefert wurden, garnicht zu deinem Gerät gehören, sondern zu einem früheren oder späterem Modell.

Müsste man aber anhand der Seriennummern, welche sowohl auf dem Gerät als auch auf der Service-Anleitung stehen (sollten) ergründen können.

Gruß Achim.

  • »hannoholgi« ist der Autor dieses Themas

Beiträge: 3 620

Registrierungsdatum: 12. November 2004

Wohnort: Am Hohen Ufer der Leine

Beruf: Funkenkutscher im Ruhestand

  • Nachricht senden

9

Donnerstag, 12. November 2015, 10:49

Hallo Achim,

also eine Röhre hat mein Exemplar definitiv nicht mehr drin! Und einen Druckfehler halte ich durchaus für möglich, weil alle anderen Bauteilwerte in der Umgebung ja identisch sind. Es müsste ja in der Beschaltung des Transistors Q401 sonst irgendwas geändert worden sein; ich finde da nix. Die Anleitung ist für Geräte mit Seriennummern, die mit 2415... beginnen. Mein Gerät hat eine solche Nummer.

Mein Generator ist in der Lage, die 50 Ohm zu treiben, er hat einen Quellwiderstand von <10 Ohm.

Ich möchte diese Sache nicht überbewerten, da ich ohnehin meist nur im NF-Bereich bis max. 150 kHz mit dem Teil messe, aber es geht mir hier ums Prinzip. Die Spezifikationen werden ja nicht mal annähernd erreicht; 500 kHz statt 10 MHz lassen doch vermuten, dass da irgendwo der Wurm drin ist!
Wenn ich den trotz eurer Hillfe nicht finde, ist es nicht sooo tragisch. ;)

Wenn ich Zeit finde, werde ich mal ein Rechteck durchschleusen. Mal sehen, was dabei rauskommt.

LG Holgi

10

Donnerstag, 12. November 2015, 19:12

Mein Generator ist in der Lage, die 50 Ohm zu treiben, er hat einen Quellwiderstand von <10 Ohm.


Der Generator hat eine Impedanz von 50 Ohm, Quelle 50 Ohm - Kabel 50 Ohm (Wellenwiderstand) - Eingang Senke (Messgerät) 50 Ohm.

Gruß Ulrich

Beiträge: 3 047

Registrierungsdatum: 20. Dezember 2015

Wohnort: bei Hamburg

Beruf: Rentner

  • Nachricht senden

11

Freitag, 1. Januar 2016, 05:12

Hallo Holgi,

besteht das Problem noch ?

Ich hab mir mal das Manual von elektrotanya downgeloaded und die Schaltungen betrachtet:
Die Spannungsangaben für Q401 in Deiner Version sind mit Sicherheit falsch, denn an dessen Emitter kann selbst wenn der Transistor zwischen E und Collektor total niederohmig würde, keine Spannung negativer als ~ - 0,07 V entstehen.( -17,5V/(3900+1000)*(10+10))..
In dem Download stehen anderswo unglaubwürdige Werte: An der Basis von Q403 werden -1,15V angegeben, am Emitter -0,94V. Laut Teileliste sind alle 3 Tansistoren aus Silizium, die haben aber typisch über der Basis-Emitterstrecke 0,6...0,7 V statt nur 0,21 V.
Die Werte im Schaltbild sind also mit Vorsicht zu genießen.
Der Trimmer C405 dient zur Frequenzgangkompensation am oberen Bereichsende. Das Manual spricht von "Vermeiden von Instabilitäten".
Das legt nahe, daß bei zu niedriger Einstellung die Verstärkung bei hohen Frequenzen sogar zunehmen würde, schlimmstenfalls, also z.B. bei probeweisem Abklemmen, das Ding sogar zum Oszillator wird. Das könnte man ja mal ausprobieren.
Wenn dann die Verstärkung "hinten" tatsächlich deutlich hochgeht oder gar Schwingungen einsetzen, würde ich den Fehler eher außerhalb des "Video-Verstärkers" vermuten.
Tritt der Fehler bei allen Stellungen des Eingangsabschwächers auf ?
Ist der Frequenzgang über Abschwächer1, Buffer und zweiten Abschwächer bis zum Eingang des "Video-Amps" ok ?
In dem Download ist übrigens noch ein Buffer mit Nuvistor (Röhre) + Transistor als dynamischer Kathodenwiderstand beschrieben. nicht die FET-Version.
Das Schaltbild ist auch ziemlich schlumig mit den Kondensatorsymbolen und Wertangaben. Selbst 150pF werden als gepolter Elko gezeichnet. Wirkliche Elkos erkennt man offenbar daran, daß der Wert nur als Zahl ohne "uF" angegeben wird.
Ziemlich bescheiden ist, daß C402 (wohl 500 uF) im Eingang und der Bootstrap Kondensator C411 (10uF) sowie all die Elkos in den Emitterpfaden und dem "Bias Stabilizing Feedback" nicht nochmal mit einigen HF-tauglichen nF überbrückt wurden.

Wie ist der Stand der Dinge ?
MfG Kai


P.S.: Dein Schaltungs-Scan wird bei mir nicht lesbar dargestellt. Eigentlich kann ich nur die Transistoren, Striche und verschwommene graue Flächen erkennen.

  • »hannoholgi« ist der Autor dieses Themas

Beiträge: 3 620

Registrierungsdatum: 12. November 2004

Wohnort: Am Hohen Ufer der Leine

Beruf: Funkenkutscher im Ruhestand

  • Nachricht senden

12

Freitag, 1. Januar 2016, 19:09

Hallo Kai,

die Sache hat sich ganz anders erledigt, als ich gedacht hatte....Peinlich... :huh: :wacko:

Der von mir zum Abgleich verwendete DDS-Generator weist bei steigender Frequenz leider keinen konstanten Ausgangspegel auf! Ich war davon ausgegangen, dass das der Fall ist. Das war ein Fehler.
Der Pegel fällt ab etwa 250 kHz langsam mit zunehmender Steilheit ab, in gleichem Maße wie die (vermeintlich fehlerhafte) Anzeige des Millivoltmeters. Das habe ich durch die Messung des Pegels mit einem anderen Millivoltmeter und meinem Oszi festgestellt. Die Messwerte in meinem Millivoltmeter stimmen weitgehend mit denen aus Ulrichs Schaltplan überein!

Damit kann ich leider mein HP 3400 A immer noch nicht sauber abgleichen, denn ich brauche dafür eben einen Generator, der bei allen Frequenzen bis 10 MHz ein wirklich konstantes Signal (± 0,5 dB) zu liefern imstande ist. Leider besitze ich einen solchen nicht und habe auch keinen Dukatenkacker, um mir einen Super-Generator für ein paar hundert oder tausend Teuro zu kaufen.

Der Generator, den ich benutze, ist ein Bausatz von Ascel-Electronic. Eigentlich konstruiert der liebe Herr Galievskij sehr gute Geräte, aber der Pegelabfall bei hohen Frequenzen ist wohl nicht zu vermeiden. Ich werde ihn aber deswegen mal anschreiben, zumal ich sowieso gerade wegen des Frequenzzählers aus der gleichen Serie mit ihm in Korrespondenz stehe.
Die Version 3.0 des DDS-Generators soll ja "verbessert" sein; vielleicht kann man da den Microcontroller tauschen.

LG Holgi

Beiträge: 3 047

Registrierungsdatum: 20. Dezember 2015

Wohnort: bei Hamburg

Beruf: Rentner

  • Nachricht senden

13

Freitag, 1. Januar 2016, 20:38

Hallo Holgi,

das ist doch aber schon mal eine gute Nachricht, daß das Millivoltmeter nur eine Abgleichüberprüfung braucht.
Da würde ich erstmal ganz pragmatisch vorgehen und nicht den Frequenzgang mit Sinus-Signalen prüfen, sondern mit dem Oszi testen, ob der DDS bei 250 kHz noch ein recht gutes Rechteck ausgibt. Wenn nicht, dann einfach ein schnelles Digital-Logik IC (Inverter oder NAND oder NOR-Gates ist egal) dahinter setzen, sodaß ein scharfes Rechteck rauskommt. Man kann auch, damit hinten mehr Leistung zur Verfügung steht, alle 6 Inverter oder 4 NANDs eines ICs parallelschalten. An den Ausgang einen Spannungsteiler, dessen Summenwiderstand das Ding gerade noch nicht überlastet und der am Abgriff 50 Ohm Impedanz hat (= Wert der Parallelschaltung der beiden Widerstände). Diese Spannung auf das Millivoltmeter geben. Wenn Du dann mit dem Oszi die Spannung am Ausgang des "Video-Amps" im HP 3400A mit C405 auf geringes Überschwingen am hinteren Ende des Rechtecks abgleichst, sollte das eigentlich einer Einstellung auf möglichst flachen Frequenzgang recht nahe kommen, bzw. es ist eigentlich Geschmacksache, was man sich als Abgleichziel setzt. Ein echtes RMS-Millivoltmeter macht sowieso erst Sinn, wenn man es nicht mehr mit Sinüssen zutun hat, denn beim Sinus ist am Verhältnis von Spitzenwert zu Effektiwert nicht mehr "zu rütteln". Man kann also genauso mit dem Scope PeakPeak messen und durch 2*sqrt(2) teilen. Interessant wird RMS-Messung erst, wenn das Verhältnis von Spitzenwert zu Effektivwert nicht bekannt ist, also z.B. bei Musik. Allerdings würde ich ein Tonbandgerät nie nach Effektivwert, sondern immer nach Spitzenwert aussteuern .
Insofern ist es schön, wenn man so ein Gerät hat, aber beim Tonbandhobby kommt man eigentlich mit Spitzenwert-Aussteuerungs-Instrumenten und einem Oszillographen gut aus.

MfG Kai

  • »hannoholgi« ist der Autor dieses Themas

Beiträge: 3 620

Registrierungsdatum: 12. November 2004

Wohnort: Am Hohen Ufer der Leine

Beruf: Funkenkutscher im Ruhestand

  • Nachricht senden

14

Freitag, 1. Januar 2016, 20:48

Vielen Dank für deine Antwort.

Ich werde im neuen Jahr, wenn meine Frau wieder arbeiten geht (dann habe ich mehr Ruhe ;) ) noch mal einen Blick auf das Ding werfen und mir das Rechteck auf dem Oszi ansehen. Allerdings kann es 10 MHz sowieso nur als Sinus.

Das Millivoltmeter benutze ich ja nicht als Aussteuerungskontrolle, sondern zum Einmessen!
Für die Pegelei habe ich ein RTW-Peakmeter:



Gruß
Holgi

Beiträge: 3 047

Registrierungsdatum: 20. Dezember 2015

Wohnort: bei Hamburg

Beruf: Rentner

  • Nachricht senden

15

Freitag, 1. Januar 2016, 21:54

Sinus macht nix, kann sogar von Vorteil sein :

1. Die Digital-Gates machen auch aus einem Sinus ein Rechteck.
2. Im Gegensatz zur Speisung mit Rechteck, kann man dann durch "Verschieben" des Sinus bezüglich der Schaltschwelle der Gates mit einer Biasspannung das Tastverhältnis wunschgemäß einstellen (allerdings kann die Schaltschwelle auch driften).

Wundert mich aber, daß der DDS nicht bis zur höchsten Frequenz auch Rechteck liefert.
Soweit ich mich entsinne, wird meist das Rechteck etwas edler mit einem ordentlichen Komparator (statt Digital-Gatter) aus dem Sinus erzeugt. Schnelle Komparatoren mit Submillivoltempfindlichkeit sind nichts Ungewöhnliches und gut geeigenet, aus ein x-hundert Millivolt Sinus ein ordentliches Rechteck mit per Offsetspannung einstellbarem Tastverhältnis zu erzeugen.

MfG Kai

Beiträge: 3 047

Registrierungsdatum: 20. Dezember 2015

Wohnort: bei Hamburg

Beruf: Rentner

  • Nachricht senden

16

Samstag, 2. Januar 2016, 12:14

Noch eine Koprrektur und eine Ergänzung meines früheren Geschreibsels:

1. Man optimiert mit C405 das Rechteck-Verhalten (Einschwingen) am vorderen Ende (nicht hinten, wie zuvor behauptet).

2. 10 MHz Rechteck wird garnicht benötigt. 0,5 MHz wäre hier eine zweckmäßige Testfrequenz. Aber die Flankensteilheit sollte für weit über 10 MHz gut sein, damit das Einschwingverhalten nicht verfälscht wird. Deshalb der Vorschlag mit den schnellen Logik-ICs.
Dafür ist natürlich auch ein Oszi mit deutlich mehr Bandbreite und ein abgeglichener Tastkopf erforderlich.

MfG Kai

17

Samstag, 2. Januar 2016, 14:27

Soweit ich mich entsinne, wird meist das Rechteck etwas edler mit einem ordentlichen Komparator


Das (*) gilt nur für analoge Generatoren, bei einem DDS Generator wird das Rechteck anders erzeugt.

(*) Mit der Einschränkung, das es sich meist um einen Komparator mit Hysterese handelt, also einen Schmitt-Trigger.
Dort liegt die obere Grenzfrequenz des Rechtecks (wie eigentlich auch beim DDS) immer deutlich unter der des Sinussignals.

Nachtrag: Ein ideales Rechtecksignal existiert nur in der Theorie, es müsste eine Anstiegs und Abfallzeit von Null haben. In der Praxis kann man sich diesem Ideal nur in bestimmter Größe annähern.

Gruß Ulrich

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »uk64« (2. Januar 2016, 15:07)


Beiträge: 3 047

Registrierungsdatum: 20. Dezember 2015

Wohnort: bei Hamburg

Beruf: Rentner

  • Nachricht senden

18

Samstag, 2. Januar 2016, 15:33

Und um diese inhärente Beschränkung auszuhebeln, greift der gewitzte Elektroniker zu einem Hex-Inverter oder einem Quad-NAND (einer schnellen Logik-Familie) aus der Bastelkiste, um sich ein Rechteck bis zur Sinus-Frequenzgrenze aus dem Gerät rausholen zu können.
Wenn man zwei Inverter oder NANDs hintereinander schaltet und dann mit einem großen Widerstand vom Ausgang auf den Vorspannung erzeugenden Spannungsteiler am Eingang zurückkoppelt, kann man sich Hysterese nach Wunsch einstellen. Man kann natürlich auch ein Schmitt-Trigger-IC aus der Logik-Familie nehmen, die sind aber in der heimischen Bastelkiste i.d.R. seltener oder garnicht vorhanden.
Diese Lösung kommt meist billiger als die Verwendung eines Komparators mit vergleichbarer Flankensteilheit am Ausgang.
Die Flankensteilheit des erzeugten Rechtecks muß natürlich nicht besser sein, als die des zum Betrachteten verwendeten Oszilloskops.
Schaden tuts aber auch nicht.

Wenn man bei einem DDS ein Rechteck mit den Flanken nahe den Nulldurchgängen des Sinus ausgeben will, ist die Komparatormethode das erste, was einem einfällt.
Der "glatte Analog"-sinus wird durch ein Tiefpassfilter aus einem digital als Treppenfunktion approximierten sinus erzeugt. Je näher man der oberen Frequenzgrenze des DDS kommt, aus umso weniger Treppenstufen pro Periode besteht der sinus.( Ginge man bis zur halben Clockfrequenz des DDS, so käme am digitalen sinus Ausgang nur noch ein Rechteck raus.) Die Lage der Nulldurchgänge des Analog-sinus wird erst durch das Tiefpass-Filter aus der Treppenfunktion generiert/interpoliert, steht also am DDS in der Regel nicht zu irgendeinem Clockevent zur Verfügung.

MfG Kai

19

Samstag, 2. Januar 2016, 16:16

der gewitzte Elektroniker


Es mag daran liege, das ich kein gewitzter Elektroniker bin :)

Im Regelfall folgt in einem realen Generator auf die Signalerzeugung eine Ausgangsstufe mit definierter Impedanz, diese Ausgangsstufe müsste fürs saubere (Definitionssache) Rechteck die zigfache Bandbreite aufweisen.

Für ein Rechteck mit 10MHz (*) kann das je nach Anspruch an Anstiegs und Abfallzeit eine erforderliche Bandbreite von 1GHz sein.
Schaue dir doch mal die Anstiegs und Abfallzeiten der schnellen Logikfamilien an.

(*) Ein 100MHz Oszi würde da nur 4 Oberwellen anzeigen, das sieht noch nicht sehr "rechteckig" aus.

Gruß Ulrich

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »uk64« (2. Januar 2016, 16:38)


Beiträge: 3 047

Registrierungsdatum: 20. Dezember 2015

Wohnort: bei Hamburg

Beruf: Rentner

  • Nachricht senden

20

Samstag, 2. Januar 2016, 18:48

Hallo Ullrich,

der "gewitzte" Elektroniker ist hier einer, angesichts der "Beschränkheit" seines Equipments nicht verzweifelt, sondern mit einfachen Improvisationsmaßnahmen doch noch zur gewünschten Wirkung kommt. Da gehörst Du bestimmt auch dazu.

Du hast offenbar einen idealisierten "Rechteck"-Begriff.
Ich meine damit alles, was man bei einfachem Blick aufs Oszilloskop nicht mehr trapezförmig nennen würde.
Das wäre bei den genannten 0,5 MHz, also 2us Periodendauer, schon bei Anstiegs- & Abfallzeiten von je 10 nsec der Fall, denn 10 ns auf 2us sieht man sicher nicht mehr.
Bezüglich der benötigen Signal-Bandbreite könnte man auch so abschätzen:
Der betrachtete "Video-Verstärker" soll bis etwa 10 MHz einen flachen Frerquenzgang bekommen.
Da drin werden NPN-Transistoren vom Typ 2N708 und ähnliche PNP Transistoren mit Transitfrequenzen von ein paar hundert MHz verwendet.
Dadurch entstehen in dem gegengekoppelten Verstärker, solange nicht mit dem Abgleichtrimmer wie bei einem OPAmp mit dem Kompensations-C für eine ausreichende Phasenreserve gesorgt wird, resonanzähnliche Verstärkungsüberhöhungen vermutlich zwischen 20 und 40 MHz.
Damit man die mit einem Testsignal sichtbar machen kann, sollte also nennenswerter Pegel bei, sagen wir mal 30 MHz drin enthalten sein.
Diese Bedingung wäre noch bei einer Flankensteilheit vo ca. 16 nsec erfüllt, denn daraus besteht z.B.ein Dreieckssignal von ca. 30 MHz.
Das geht vielleicht sogar noch mit MOS-ICs aus der HCT-Serie.
Gigaherzen sind also nicht nötig, 100 MHz wär schön, aber mt einem 30 MHz Scope sieht man bestimmt auch noch was.

MfG Kai

21

Samstag, 2. Januar 2016, 19:22

Ich glaube, wir haben wirklich aneinander vorbei geschrieben.

Ich bezog mich darauf:

Wundert mich aber, daß der DDS nicht bis zur höchsten Frequenz auch Rechteck liefert.


Das ist halt ganz normal, das ein Generator (Analog oder DDS) bei der höchsten Frequenz kein Rechteck mehr liefert.

Das hier ein Rechteck mit wesentlich geringerer Frequenz ausreicht ist klar, schau mal was ich in Beitrag 6 geschrieben hatte.

Gruß Ulrich

Beiträge: 3 047

Registrierungsdatum: 20. Dezember 2015

Wohnort: bei Hamburg

Beruf: Rentner

  • Nachricht senden

22

Samstag, 2. Januar 2016, 19:59

Oh ja, tatsächlich...
Im "schlecht Gucken" werd ich immer besser und im Vergessen immer schneller... :-)

Die Aussage zum DDS wurde aus abgekürzter Schreibweise mißverständlich.
Damit war nicht das DDS-IC, sondern der DDS-basierte Generator gemeint, weil, wie weiter oben ausgeführt, sich man ja nicht mit den Beschränkungen des ICs abfinden muß.

Die wünschenswerten Umschaltzeiten des Rechtecksignals kann man auch aus den Schaltzeiten der verwendeten Transistoren abschätzen, wenn man denn noch Datenblätter findet. In einem SPICE-Modell für den 2N708 wurden zwei Werte von 4,x und 8,x nsec angegeben.
Besser muß das Testsignal dann auch nicht sein.

MfG Kai

23

Samstag, 2. Januar 2016, 21:08

Ja, ich gebe zu, auch ich bin heute nicht "Gut drauf". Silvester wirkt noch nach.

Gruß Ulrich