You are not logged in.

Dear visitor, welcome to Bandmaschinenforum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

  • "BertilAlving" started this thread

Posts: 1

Date of registration: Feb 23rd 2014

Location: Stockholm, Sweden

Occupation: Recording engineer

  • Send private message

1

Thursday, March 6th 2014, 1:38am

Telefunken M10, graphite brake drum is stuck!!!

Several years ago I bought a Telefunken M10 and now I would like to spend some work for getting the machine in usable condition. The main problem is that the left graphite drum for the double brake mechanism was stuck on the axis and almost half of the graphite drum was separated from the rest (i bought it in this condition, however I still have that broke-away part of the graphite ring).

Here you can see how it looks like:




As I understand many M10 machines suffers from the stuck brake problem. So, any ideas why the graphite drum is stuck and can anyone suggest how to solve the problem? How to get the graphite drum loose from the axis, and do you think it would be possible to use super glue for getting the two parts of the graphite drum together again (they fit very well together, no more graphite material is missing)?

Thanks for every help and suggestions,
Bertil