You are not logged in.

  • "kaimex" started this thread

Posts: 3,893

Date of registration: Dec 20th 2015

Location: bei Hamburg

Occupation: Rentner

  • Send private message

1

Saturday, October 27th 2018, 11:58am

ffmpeg update für linux mint 18.2 ?

Hallo Linux-Spezis,

auf meinem Internet-LapTop werkelt unter Linux Mint 18.2 die ffmpeg Version 2.8.15 .
Etwas Neueres finde ich auch nicht in der "Synaptic Paketverwaltung".

Seit ich gestern bei FFmpeg.org gesehen habe, daß die aktuelle Version 4.0 vom 20.4.2018 ist und dort angepriesen wird mit
"We strongly recommend users, distributors, and system integrators to upgrade unless they use current git master.",
komme ich mir ziemlich veraltet vor.
Als Nicht-Linux-Spezi bin ich jedoch ratlos, ob und wie ich die neue Version problemlos installieren kann.

Über sachdienliche Hinweise würde sich freuen
Kai

Posts: 1,128

Date of registration: Apr 17th 2009

Location: Am Remstal

  • Send private message

2

Saturday, October 27th 2018, 1:52pm

Hallo Kai,

im Prinzip schon, allerdings wird eine separate, manuelle Installation nicht vom Paketmanagment erfasst. Die Mintversion am besten deinstallieren und manuell in /usr/local oder /usr/opt installieren. Updaten mußte Du dann immer manuell. Ansonsten warten, es dauert immer ein wenig, bis das von den Paketmaintainern freigegeben wird, dann geht es automatisch über das Distributionsupdate. Dringende Updateempfehlungen werden eigentlich nur bei kritischen Sicherheitsupdates gegeben, die kommen in der Regel auch recht kurzfristig in die Distributionen, daher haben die Entwickler hier auch vornehmlich die Distributoren angesprochen. Ich würde in meinem Fall eher warten, bis es in das reguläre Systemupdate kommt. Zumeist sind die Änderungen nur marginal.
Gruß
André

Posts: 13,215

Date of registration: Apr 4th 2004

Location: Meerbusch (bei Düsseldorf)

Occupation: Softwareentwickler

  • Send private message

3

Saturday, October 27th 2018, 4:34pm

im Prinzip schon, allerdings wird eine separate, manuelle Installation nicht vom Paketmanagment erfasst.


Man kann sich sein .deb-Paket selber bauen (was unter Debian-basierten Distributionen auch der empfohlene Weg für manuelle Updates von Paketen ist), dann ist die neue Version auch vom Paketmanagement registriert. Es ist allerdings etwas Aufwand, das wirklich ordentlich zu machen.

Ubuntu 18.10 hat übrigens schon ffmpeg 4. Da das Update sicherheitskritisch ist, wird Mint hoffentlich schnell nachziehen.,


Posts: 2,928

Date of registration: Dec 11th 2012

Location: North of Frankfurt/Main

  • Send private message

4

Saturday, October 27th 2018, 5:31pm

Mint 19 hat z.Zt. ffmpeg 3.4.4.
Vermutlich muss zuerst ein dist-upgrade auf 19.x erfolgen müssen, damit alle neuen Libs installiert sind.

  • "kaimex" started this thread

Posts: 3,893

Date of registration: Dec 20th 2015

Location: bei Hamburg

Occupation: Rentner

  • Send private message

5

Saturday, October 27th 2018, 7:17pm

Erst mal danke für die Hinweise.

Ein bischen suchen nach dist-update von Linux Mint 18.x nach 19.x ergab leider, daß das keine einfache Sache ist, insbesondere für 18.2 wohl noch mehr als für 18.3 .
An einer Fundstelle wurde geraten, eine Neu-Installation auf einer freien Partition vorzunehmen.
Das erscheint mir auf diesem kleinen älteren LapTop aber nicht angezeigt...

Da muß ich wohl bei dem bleiben, was ich hab, oder einen neuen PC dazu anschaffen...
oder ffmpeg unter Windows benutzen.

MfG Kai

Posts: 2,928

Date of registration: Dec 11th 2012

Location: North of Frankfurt/Main

  • Send private message

6

Saturday, October 27th 2018, 7:34pm

Das ist Blödsinn mit Neuinstallation. Das kannst du dann machen, wenn das Upgrade schief geht. D.h. vorher "/etc" und "/home" auf eine externe Platte sichern. Oder "timeshift" installieren und das Backup machen.

Im "Update-Manager" (ich habs nur in Englisch hier, da sollte aber ein Icon unten rechts im Panel sein) unter den Menüpunkten suchen. Da steht irgendwo "Upgrade auf 18.3". Du musst den Zwischenschritt über 18.3 machen, bevor du auf 19 kannst. Diese Anleitung funktioniert: https://blog.linuxmint.com/?p=3462. Dann kommen ein paar Sicherheitsabfragen, elendig viel zum Download und nochmal etliche Zeit für die installation. Du solltest mit 1-2 Stunden rechnen, je nach Geschwindigkeit des Downloads und Rechners. Es gibt auch Möglichkeiten, das Upgrade durchzuspielen. Nach dem Upgrade und dem Reboot erstmal wieder alle Updates einspielen. Dann findest du das Upgrade auf 19 an der gleichen Stelle ...

Gruß
Michael

Posts: 2,928

Date of registration: Dec 11th 2012

Location: North of Frankfurt/Main

  • Send private message

7

Saturday, October 27th 2018, 7:36pm

Ach ja, vielleicht auch gleich den Kernel etwas modernisieren. 4.15 läuft problemlos. Geht auch im Update-Manager.

  • "kaimex" started this thread

Posts: 3,893

Date of registration: Dec 20th 2015

Location: bei Hamburg

Occupation: Rentner

  • Send private message

8

Saturday, October 27th 2018, 8:09pm

Hallo Michael,

Das ist Blödsinn mit Neuinstallation.

die Fundstelle hatte selbst von "clean update to a separate partition" o.ä. gesprochen, was ich in Neu-Installation verkürzt habe.
Die Stelle kann ich nun aber garnicht mehr wiederfinden.
Stattdessen hab ich jetzt zB:
https://www.tecmint.com/upgrade-to-linux-mint-19/
die sich dann im Detail erst über einen Update zu 18.3, einen snapshot und dann einen update von 18.3 zu 19 ausläßt.
Ich habe noch nicht mit deinem Link verglichen, ob es inhaltlich das Gleiche ist.
Da ich mit dem APT package manager nicht vertraut bin, müßte ich mich da erstmal einlesen oder die Finger davon lassen.

Findet man eigentlich alles, was man dazu downloaden müßte, auch auf aktuellen DVDs einschlägiger Fachzeitschriften ?

MfG Kai

Posts: 2,928

Date of registration: Dec 11th 2012

Location: North of Frankfurt/Main

  • Send private message

9

Saturday, October 27th 2018, 8:16pm

Warum schreibe ich eigentlich Links in meinen Beitrag, wo man den Upgrade Prozeß nachlesen kann? Damit ich im nächsten Beitrag einem anderen Link auf eine andere Seite folgen muss und mich dort erst einlesen? Wo dann immerhin genau das steht, was ich vorher geschrieben habe? Neee, die Zeit kann ich mir schenken.

Sorry dafür,
Michael

  • "kaimex" started this thread

Posts: 3,893

Date of registration: Dec 20th 2015

Location: bei Hamburg

Occupation: Rentner

  • Send private message

10

Sunday, October 28th 2018, 9:22am

Hallo,

ich habe das "Problem" dadurch erledigt, daß ich das aktuelle Windows 64Bit Release unter Windows 7 entpackt habe.
Läuft ohne weitere Aktionen auf Anhieb.

MfG Kai

Posts: 1,128

Date of registration: Apr 17th 2009

Location: Am Remstal

  • Send private message

11

Sunday, October 28th 2018, 12:38pm



Man kann sich sein .deb-Paket selber bauen (was unter Debian-basierten Distributionen auch der empfohlene Weg für manuelle Updates von Paketen ist), dann ist die neue Version auch vom Paketmanagement registriert. Es ist allerdings etwas Aufwand, das wirklich ordentlich zu machen.

Das kann man zwar machen, ist aber gefährlich, denn dadurch kann es zu Inkompatiblitäten kommen, die dann zukünftige System-Updates wegen unaufgelösten Paketabhängigkeiten verhindern. Dann hat man erneut Frickelei. Eine manuelle Installation kann man im Zweifelsfall einfach löschen und wird ansonsten nicht vom Paketmanagement berücksichtigt.
Gruß
André

Posts: 13,215

Date of registration: Apr 4th 2004

Location: Meerbusch (bei Düsseldorf)

Occupation: Softwareentwickler

  • Send private message

12

Sunday, October 28th 2018, 4:54pm


Das kann man zwar machen, ist aber gefährlich, denn dadurch kann es zu Inkompatiblitäten kommen, die dann zukünftige System-Updates wegen unaufgelösten Paketabhängigkeiten verhindern. Dann hat man erneut Frickelei.


Das schlimmste, was einem passieren kann, ist doch, daß man das selbstgebaute Paket wieder deinstallieren (und wieder die alte Version aus den Repositories installieren) muss, damit irgendwelche Abhängigkeiten aufgelöst werden können. Halte ich für ein kalkulierbares Risiko.

Posts: 1,128

Date of registration: Apr 17th 2009

Location: Am Remstal

  • Send private message

13

Sunday, October 28th 2018, 8:25pm

Nicht immer, selbst das kann schon zu Abhängigkeitsproblemen führen. Sicher ist früher oder später alles zu fixen, aber man hat erstmal den Streß, ob der nun die neueste Version wert ist?
Gruß
André